Results 1 to 5 of 5

Thread: Double Quotes on Input & Output

  1. #1

    Default Double Quotes on Input & Output

    I have some data that is delimted as follows. Some of the data fields has double quotes.

    Example data:

    "07777777777"¦277933294¦572537575¦"013190008122677 "¦"0065435930054"¦153379907¦-1¦"NONE"¦

    I am trying to load the data into Lavastorm maintaining the double quotes (existing format). I have achieved this with the node below:

    node:New_Format_PIE_Data_2
    bretype:core::Delimited File
    editor:Label=New Format PIE Data
    editor:sortkey=506c2ed65dee6290
    input:506c2ed655091bb3/=QA_Location.40fd2c747c2b1c0a
    output:@41e6c6cd11e613c6/=
    prop:FieldDelimiter=¦
    prop:FilenameExpr=<<EOX
    Filename
    EOX
    prop:QuotedDoubleQuotes=Literal Quote if no EscapeCharacters
    prop:RecordDelimiter=\n
    editor:XY=190,130
    end:New_Format_PIE_Data_2

    I am then trying to export (publish) the data so it is exactly the same as the import data - however I cannot seem to manage this as if I select "False" on the DoubleQuote I need to select an EscapeCharacter - however I do not want an escape character?

    I have tried numerous combinations all to no avail - Please help!

    Thanks

    Andy

  2. #2

    Default

    Hi Andy,

    Can you provide an example of how you are trying to publish the data?

    Thanks,
    John

  3. #3

    Default

    John,

    I am trying to publish using the node Output Delimited - below is the node I want to run but it gives an error. This seems to require an escape character to be defined, however if I enter a character the output is not the same as the input format:

    node:Output_Delimited_3
    bretype:core::Output Delimited
    editor:sortkey=512cae3446fd0ed1_2
    input:@43c680084b824568/=New_Format_PIE_Data.41e6c6cd11e613c6
    prop:DoubleQuote=false
    prop:FieldDelimiter=¦
    prop:File=\\cpwcentral\DATAWARE\Export\CONNECTION_ REPORT_FOR_ACCURATE\QA\Andy\Lavastorm_Outputv2.dat
    prop:RecordDelimiter=\n
    prop:WhenToQuote=Minimal
    editor:XY=350,280
    end:Output_Delimited_3

    Regards

    Andy

  4. #4
    Lavastorm Employee
    Join Date
    Aug 2009
    Location
    Cologne
    Posts
    513

    Default

    Hey,

    After playing around a little, if you specify the quote character to be the same as the field delimiter character (¦), then it looks like this works as you want.
    Leaving the other optional parameters (EscapeCharacter, DoubleQuote, WhenToQuote) as the default (empty) values results in the output which is the same format as your input data.

    Still, this isn't obvious at all, and there should be the option for specifying that there are no quote characters (which is an option on the Delimited File node but not on the Output Delimited node).
    Either that, or this mechanism should really be documented.
    I have added an enhancement request to either add this ability to the Output Delimited node or properly document how to use the QuoteCharacter to get the type of output you want (issue # 4742).

    Regards,
    Tim.

  5. #5

    Default

    Tim,
    Thanks a lot - this gives me the output I was after (although I do not quite understand the logic to why it works). I agree the output delimited node should mirror the input delimited node - hopefully this can be delivered as a future enhancement.

    Regards
    Andy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •