Results 1 to 4 of 4

Thread: node runs, but no data retrieved using my id

  1. #1
    Contributor
    Join Date
    Oct 2012
    Location
    Columbus, GA
    Posts
    6

    Default node runs, but no data retrieved using my id

    DB Query node used to run known valid SQL retrieves no data when my id is used, but retrieves data fine when run on my machine with another users id (Cyndi Helms). Cyndi runs it fine on her machine as well, but can't with my ID.

    I run the query and get data when using SQL Assistant (Teradata).

    What is different here that is causing the issue?

  2. #2
    Contributor
    Join Date
    Dec 2006
    Location
    Boston
    Posts
    485

    Default

    Gloria, are you using CLI or ODBC for your connection? Are you sure the SQL Assistant is using the same credentials that you are trying to use in the DB Query node? It sounds like a configuration / environment issue (improper rights to the user id).

    Cheers
    Rich

  3. #3
    Contributor
    Join Date
    Oct 2012
    Location
    Columbus, GA
    Posts
    6

    Default

    the interface is CLI, same for both ids. ODBC is used in the other tool, but BRE is not recognizing those drivers on my machine. I have issued a ticket internally to verify if there are any differences in the two userids relative to the database queried. our profiles indicate there aren't.

  4. #4
    Contributor
    Join Date
    Dec 2006
    Location
    Boston
    Posts
    485

    Default

    It definitely sounds like an environment issue, and specifically a user profile configuration. Especially given that you can run queries successfully in both environments using someone else's id, but not your own. I suspect the reason SQL Assistant is working is either that you are using a different set of credentials in there, or our connection requires a slightly different set of permissions. It seems likely the ticket you opened internally is the correct path, good luck!

    Cheers
    Rich

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •