Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: how to write a field value into a messagebody of send email+ node?

  1. #1

    Question how to write a field value into a messagebody of send email+ node?

    I am going to send a email in my graph. I use the send email+ node to send email. The input to the send email+ node is a cat node. And I am trying to write the values of fields in the cat node to the MessageBody of the send email+ node. Can anybody tell me how to do that? I got a plain text in my email every time I try to use the values of the fields. thanks.

  2. #2

    Default

    I have the same question. How to write values of fields into the MessageBody?

  3. #3
    Lavastorm Employee gmullin's Avatar
    Join Date
    May 2014
    Location
    Chicago
    Posts
    134

    Default

    Have a look here.

  4. #4

    Default

    Thanks for the reply, gmullin. I tried your way, but it seems it doesn't work for me. I will describe my simple graph to you.
    The input of send mail+ is a filter node which has a field named DateTime in which I got the string including the current date and current time. Then in the MessageBody of the Send Email+ node, I input the DateTime. I hope that the value of the DateTime field can be sent out to a email address. But when I open the email, the email body is the plain text DateTime, not the value of the DateTime field. I don't know what's wrong. And my bre version is v6.1.4. Can you guys please give me some help? Thanks.

  5. #5
    Lavastorm Employee gmullin's Avatar
    Join Date
    May 2014
    Location
    Chicago
    Posts
    134

    Default

    In the drop down beside MessageBody do you have it set to Field and not Literal?

    Can you attach your graph here?

  6. #6

    Default

    hi, gmullin, thank you very much. I got it.

  7. #7

    Default

    Thanks very much. Can I ask you more questions about the Send Email+ node?
    The first one is: I have three columns. I input three rows in the MessageBody: 1 TheStartTime, 2 TheEndTime, 3 TheGraphName. But I got an error which is ERROR:Column is missing.
    The second one is: I tried to mixed the literal and field together. I input "The Start Time is: " + TheStartTime into the MessageBody. I got the same error: ERROR:Column is missing.

    Can anybody help, please?

  8. #8
    Lavastorm Employee gmullin's Avatar
    Join Date
    May 2014
    Location
    Chicago
    Posts
    134

    Default

    You can't mix Literal/Field values, you have to pick one or the other. What you should do is have a Filter node leading into the Send + node and have something like the following:

    emit "The Start Time is: " + TheStartTime as "MessageBody"

    The you have a field called MessageBody you can use as an input.

  9. #9

    Default

    Ok, got it. Thanks a lot.

  10. #10
    Contributor
    Join Date
    Apr 2011
    Location
    Copenhagen
    Posts
    129

    Default

    Everything works fine here except when I try to use a field as input in the "MessageBody", then I get this message, even if the column is there:

    ERROR: Column is missing: (MessageBody )
    Error Code: ls.brain.node.sendEmailPlus.errorColumnMissing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •